find and solve || findandsolve.com
Please wait.....

An error occurred while processing your request.Request ID: 80001562-0000-db00-b63f-84710c7967bb Development Mode Swapping to Development environment will display more detailed information about the error that occurred.



An error occurred while processing your request.
Request ID: 80001562-0000-db00-b63f-84710c7967bb

Development Mode
Swapping to Development environment will display more detailed information about the error that occurred.

The Development environment shouldn't be enabled for deployed applications. It can result in displaying sensitive information from exceptions to end users. For local debugging, enable the Development environment by setting the ASPNETCORE_ENVIRONMENT environment variable to Development and restarting the app.


ANSWER


SOLUTION:
We have managed to resolve this issue. If it occurs for anyone else, our fix was to install the VS 2017 C++ x64 redistributable on our target environment.

DOWNLOAD LINK:
https://go.microsoft.com/fwlink/?LinkId=746572

If this is not success then you will try it

First you should  check the value of ASPNETCORE_ENVIRONMENT variable.There are two types of enviroment variable "Production" or other environment than "Development" you will have to set this environment.

 Otherwise,you can update web.config like as given below

<configuration>
  <!--
    Configure your application settings in appsettings.json. Learn more at http://go.microsoft.com/fwlink/?LinkId=786380
  -->
  <system.webServer>
    <handlers>
      <add name="aspNetCore" path="*" verb="*" modules="AspNetCoreModule" resourceType="Unspecified" />
    </handlers>
    <aspNetCore processPath=".\Application.exe" arguments="" stdoutLogEnabled="false" stdoutLogFile=".\logs\stdout" forwardWindowsAuthToken="false">
      <environmentVariables>
        <environmentVariable name="ASPNETCORE_ENVIRONMENT" value="Production" />
      </environmentVariables>
    </aspNetCore>
  </system.webServer>
</configuration>

OR

<environmentVariables>
     <environmentVariable name="ASPNETCORE_ENVIRONMENT" value="Development" />
</environmentVariables>

OR


Pleae check in launchSetting.json file. as given below

"profiles": {
    "IIS Express": {
      "commandName": "IISExpress",
      "launchBrowser": true,
      "environmentVariables": {
        "ASPNETCORE_ENVIRONMENT": "Production"
      },
      "nativeDebugging": false
    },
    "Ecommerce": {
      "commandName": "Project",
      "launchBrowser": true,
      "environmentVariables": {
        "ASPNETCORE_ENVIRONMENT": "Production"
      },
      "applicationUrl": "https://localhost:5001;http://localhost:5000"
    }
  }

Change "ASPNETCORE_ENVIRONMENT": "Development" to "ASPNETCORE_ENVIRONMENT": "Production"

Sundar  Neupane

Sundar Neupane

I like working on projects with a team that cares about creating beautiful and usable interfaces.

Comments



Report Response